SemanticUI and Aurelia installation error


#1

Hi everyone,
I’m stuck installing SemanticUI alongside the Aurelia framework.
I started a new Aurelia CLI project with:
$ au new
and named it “semantic-cli”. Then I:
$ cd semantic-cli
$ npm install
$ npm install semantic-ui --save
and I get the following error:

semantic-ui@2.2.4 install /home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/semantic-ui
gulp install

[15:55:33] Using gulpfile ~/tests/web/aurelia/customized/semantic-cli/node_modules/semantic-ui/gulpfile.js
[15:55:33] Starting ‘install’…

[15:55:33] ‘install’ errored after 93 ms
[15:55:33] TypeError: gulp.hasTask is not a function
at /home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/run-sequence/index.js:19:22
at Array.forEach (native)
at verifyTaskSets (/home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/run-sequence/index.js:13:11)
at runSequence (/home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/run-sequence/index.js:92:2)
at Gulp.module.exports (/home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/semantic-ui/tasks/install.js:450:1)
at module.exports (/home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/orchestrator/lib/runTask.js:34:7)
at Gulp.Orchestrator._runTask (/home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/orchestrator/index.js:273:3)
at Gulp.Orchestrator._runStep (/home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/orchestrator/index.js:214:10)
at Gulp.Orchestrator.start (/home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/orchestrator/index.js:134:8)
at /home/alex/tests/web/aurelia/customized/semantic-cli/node_modules/semantic-ui/node_modules/gulp/bin/gulp.js:129:20
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm ERR! Linux 4.7.5-1-ARCH
npm ERR! argv “/usr/bin/node” “/usr/bin/npm” “i” “semantic-ui” “–save”
npm ERR! node v6.9.1
npm ERR! npm v3.10.8
npm ERR! code ELIFECYCLE

npm ERR! semantic-ui@2.2.4 install: gulp install
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the semantic-ui@2.2.4 install script ‘gulp install’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the semantic-ui package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! gulp install
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs semantic-ui
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls semantic-ui
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/alex/tests/web/aurelia/customized/semantic-cli/npm-debug.log

the node / npm versions are reported in the error log, whereas:
$ gulp --version
[16:07:54] CLI version 3.9.1
[16:07:54] Local version 4.0.0-alpha.2
I update all of these to the latest versions but I still had no luck…
Any idea how can I fix this?